Archive for Januar, 2009

Perl 5.8.9-Fehler

Freitag, Januar 30th, 2009

Wieder mal einer dieser merkartigen Fehler: Ich habe ein frisches FreeBSD7.1 auf einem Xeon mit 1GB RAM und 2 SCSI-Platten im Software RAID-1 installiert. Ports-Tree geladen und wollte dann die eine oder andere Anwendung installieren: Ruby, portupgrade, Midnight Commander, … und spaetestens der Midnight Commander faengt an als Abhaengigkeit ein Perl haben zu wollen. Mitten drin brach das ganze aber mit folgendem Fehler ab:


==> Your Makefile has been rebuilt. <==
==> Please rerun the make command. <==
false
*** Error code 1

Stop in /usr/ports/lang/perl5.8/work/perl-5.8.9/ext/DynaLoader.
make config failed, continuing anyway...
Makefile out-of-date with respect to Makefile.PL
Cleaning current config before rebuilding Makefile...
make -f Makefile.old clean > /dev/null 2>&1
../../miniperl "-I../../lib" "-I../../lib" Makefile.PL "INSTALLDIRS=perl" "INSTALLMAN3DIR=none" "PERL_CORE=1" "LIBPERL_A=libperl.so"
Writing Makefile for DynaLoader
==> Your Makefile has been rebuilt. <==
==> Please rerun the make command. <==
false
*** Error code 1

Stop in /usr/ports/lang/perl5.8/work/perl-5.8.9/ext/DynaLoader.
*** Error code 1

Stop in /usr/ports/lang/perl5.8/work/perl-5.8.9.
*** Error code 1

Stop in /usr/ports/lang/perl5.8.
*** Error code 1

Stop in /usr/ports/lang/perl5.8.

Das fand ich dann ein wenig bedenklich. Also fing ich an zu gruebeln, was das sein koennte. Der Versuch ein frisches FreeBSD-Grundsystem zu installieren, scheiterte daran, dass irgendwelche Dateien nicht kopiert werden konnten, weil sie angeblich nicht existierten. Warum aber lief dann bitte das buildworld durch? Neuinstallieren und nochmal probiert. Aenderte nichts, das Perl brach beim selben Fehler wieder ab. Ich weiss nicht mehr genau bei welchem Befehl es war, aber irgendwann gab mir ein Kommando mal zurueck, dass das Systemdatum nicht stimmte. Bah! Widerliches Zeug, also Systemdatum korrigiert und auf ein neues Perl kompiliert – siehe da: geht doch!

Achja, fast haette ich es vergessen, zwischenzeitlich versuchte ich dann auf dem mit dem falschen Systemdatum nochmal ein aelteres Perl (5.6 oder so). Das hatte einen anderen lustigen Effekt: es hing in irgendeine Endlosschleife und erzeugte immer neue Shell/make-Prozesse.

Was es nicht alles gibt und was ein falsches Systemdatum nicht alles anrichten kann. Genug davon für heute, ich geh schlafen.

Plesk 9-Problemchen

Mittwoch, Januar 7th, 2009

Ich habe vor einiger Zeit von Plesk 8 auf Plek 9 umgestellt. In der Hoffnung, dass die Parallels-Leute einiges dazugelernt haetten. Aber das war wohl leider noch nicht der Fall. Es sind viele Schritte in die richtige Richtung getan worden (z.B. Umstellung von QMail auf Postfix), aber so buggy haette die Software niemals unters Volk gehen duerfen. Einer der boesesten Fehler haengt mit der Gross- und Kleinschreibung bei Domainnamen und eMail-Adressen zusammen. Sobald Grossbuchstaben im Spiel sind, kommen keine Mails mehr an. Sie werden allerdings auch nicht zum Absender zurueckgeschickt, sondern verschwinden einfach irgendwo. Ich weiss noch nicht wo, aber das finde ich noch heraus. 🙂

[Update 2009/03/16:] In den vergangenen Tagen gabs mal wieder ein bisschen Sorgen mit dem Mailing. Einige Mails (an info@) verschwanden, also gings mal wieder auf die Suche. Dabei bin ich ueber die postqueue gestolpert – da waren die ganzen nicht zugestellten Mails also hin. Schwuppdiwupp aussortiert und dann die Queue einfach mal ausgeleert. Danach dann weitergesucht, warum einige Mails zugestellt wurden und einige nicht. Dabei fand ich – wieder mittels postqueue -p – heraus, was das eigentliche Problem war. Der hostname-Eintrag in der main.cf war nicht korrekt. Dazu kamen noch zwei Begrenzungen fuer Postfachgroessen, die ich anpassen musste.